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Product Interface Design using Axure RP Pro 7.0
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Topics Covered:

- Exporting device image from Photoshop to Axure RP.

- Widgets: Image, Label, Inline Frame, Button and Shape.

- Global Guides for placing interface elements.

- Use of Global Variables to record the current state of the device.

- Creating and reusing Widget Styles.

- PageLoad and OnClick cases

- Multiple cases based on the value of a global variable.

- Animating widgets using the Move action.

- Using buttons to navigate between pages.

- Using buttons to open pages in Inline frames.

- Using Dynamic Panels to replicate interface elements.

- Using buttons to navigate Dynamic Panels.
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Open the PSD file containing all three rendered views of the redesigned Kodak PlaySport in Photoshop. Choose Image > Image Size… and 
set the resolution to 72 dpi and the image size to 1024 x 768 or smaller. 
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Turn the visibility of the layer containing the screen display image and the reflection OFF by clicking on the eye icon before the layer thumbnail 
in the Layers Panel. 
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Choose File > Save for Web… and save the file as a PNG-24 image. 
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Hold down Alt and click on the eye icon for the reflection layer to turn only that later ON and hide all the other layers. Increase the opacity of 
the layer to 100% and make sure the document background is transparent. Save the image in PNG-24 format using the File > Save for Web… 
command. 



School of Industrial Design ID 3103 - Intro to Computing I Prof. Tim Purdy

Open Azure RP Pro 7.0 and create a new file by choosing File > New… 
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Change the name of the first page to ‘Device’ in the Sitemap panel on the left. Drag and drop an image widget from the Widget Library onto 
the top left corner of the page (snap it to 0,0). 
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Double-click on the image widget to bring up the browse dialog box. Navigate to the device image file saved from the previous step in 
Photoshop and open it. Choose NO on the both the pop-up boxes to accept optimizing the image and auto-sizing the image on the page. 
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Drag an Inline Frame widget from the library onto the page. Resize and position it over the device in place of the display. 
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Right click on the inline frame widget and choose ‘Never Show Scrollbars’ to hide the scroll bars. Right click again and choose ‘Toggle Border’ 
to hide the border around the Inline Frame. 
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Rename the pages in the tree to correspond to the each screen on the device (Off Screen, Recording, Home Screen, Settings etc.) Right click 
and choose Add > Sibling page After to create a new page below the current one. 
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Create child pages for each option in the settings menu of Kodak PlaySport (1080p, 720p etc.). 
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Rename the pages to correspond to the content that will be displayed. 
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Drag another image widget to the top left corner of the Device page. Double click on it and navigate to the reflection image and open it. 
Choose NO in the Optimize Image pop-up box and YES in the Auto-size image pop-up box. This ensures that the transparency in the 
imported PNG file remains intact. 
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Reduce the opacity of the reflection image in the Widget Style panel on the right. 
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Open the Global Variables dialog box from the Project menu. 
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Create five global variables and set their default values as shown. These variables are used to keep track of the current state of the device. 
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Select the Inline frame on the Device page and note the value of the Height and Width of the inline frame widget (222 x 170) in the Device 
page. 
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In the Off Screen page hold down Ctrl and drag from the vertical and horizontal rulers to create two global guides at 222 and 170 respectively. 
Global guides are magenta colored and appear on all the pages in the document. 

222 px

170 px
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In the On/Off Logo page, set the page background to black in the Page Style panel. Using the image widget, place the Kodak logo in the On/
Off Logo page. Center it with respect to the two global guides. 
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In the Home Screen page, drag and drop an image widget to place the place holder image for the device. Resize it to match the size of the 
inline frame by snapping to the Global Guides. Double click on the image widget and choose a placeholder image. 
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Use the rectangle widget to create a rectangle at the bottom of the screen to use as the underlay for the bottom menu in the interface. 
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Open the Widget Style Editor window from the Widget Style panel on the right. Create a new style by clicking on the ‘+’ and set a name (Black 
Underlay). Specify a fill color and opacity. This style will be used for all shapes that serve as underlays in this document. 
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Select the rectangle and apply the Black Underlay Style by selecting it from the list in the Style panel. 
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Drag and drop a Label widget from the library. Open the Widget Style Editor window to create a new style for active text objects. Click OK to 
close the window and apply the style to the label. 
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Change the name of the label in the shape name box in the top right. 
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Using image widget insert the icons for the battery and SD card. You can create icons in Illustrator and save them as PNG images or find 
stock images online (The Noun Project, Brands of the world etc.)  
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Select all the items in the Home Screen page and copy it (Ctrl + C). 
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Paste the items in the Recording page and all the Settings pages. Drag another rectangle widget from the library to use as the recording 
indicator. 
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Click on the small gray circle in the top right corner of the rectangle, to bring up the shape chooser and select a circle. 
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Resize the shape and change the fill color and opacity in the Style panel to mimic a recording indicator. 
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Drop a new label widget and change the text to ‘Recording…’ Apply the Active Text style to it by selecting it from the Base Style drop down 
menu in the Style panel. 
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Repeat previous steps to create the settings menu in the Settings 1080p page. Use the Black Underlay widget style for all the rectangles and 
Active Text style for the text. 
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Copy the settings menu and paste it in all the Settings pages. 



School of Industrial Design ID 3103 - Intro to Computing I Prof. Tim Purdy

Create a new Widget Style for the active settings item called Blue Underlay. 
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Apply the Blue Underlay style for the active settings item in each Settings page. 
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In the Device page, create shape overlays using widgets for all the buttons that the user will be interacting with. These shapes help identify 
clickable hotspots in the interface mockup preview. 
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Create a widget style for all the shapes that serve as button overlays. Name each button appropriately (power_btn, up_btn, down_btn. 
record_btn etc.) 
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Create a Recording Indicator using a shape widget. 
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Select the Inline frame in the Device page and enter a name in the box in the top right. 
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With the Device page active, double-click on the OnPageLoad case under the Page Interactions panel to bring up the Case Editor. 
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Case 1 is executed when the Device page loads. Choose Show/Hide Widgets from the actions list and hide all the button overlays (except the 
power_btn overlay) as these buttons should not be visible until the device is turned on. 
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Set the inline frame to display the Off Screen. 
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Select the power_btn and double-click on the OnClick case in the Widget Interactions panel to bring up the Case Editor. 
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In the Case Editor, click on the Add Condition to open the Condition Builder. 
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Enter the condition to check if the powerOnOff variable is OFF. This ensures that the power_btn functions as the ON switch when the device is 
OFF. 
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Set to load the On/Off Logo page in the inline frame. 
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Enter a wait time of 3000 ms. This gives enough time for the logo to animate in the On/Off Logo page. 
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Set to open the Home Screen in the inline frame after the 3000 ms wait. 
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Turn the Record Button and Settings Button ON by using the Show Widget action. 
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Set the value of the powerOnOff variable to ON to indicate that the device is ON. 
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In the On/Off Logo page, select the Kodak logo and make note of the current position of the Kodak logo (60, 60). 
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Drag the logo outside the visible screen area. The logo will be animated back to its original position when the page is loaded. 
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Enter a name for the logo in the Image Name box in the top right and double-click on the OnPageLoad case under thew Page Interactions 
panel to set the actions that will be executed when the page loads. 
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Set the logo to move back to its original position using the Move widget action. Enter the original location of the logo (60,60) in the Move To 
section. Enter a time value lesser than 3000 ms to ensure that the animation is completed before the Home Screen loads. 
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Select the recording indicator and name it appropriately. 
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Select the recording button and double-click on the OnClick case to open the Case Editor for the record_btn. 
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Open the Condition Builder and set the condition to verify the current state of the recordOnOff variable is OFF. 
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When the record_btn is clicked the Recording screen has to be displayed in the inline frame and the recording indicator has to pulse. Use the 
Open Link in Frame action to open the Recording page in the Inline frame and choose to Show the recording indicator. 
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Add wait time and toggle between Hide and Show for the recording indicator to create a pulsing animation. 
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Set the value of the recordOnOff variable to ON. This indicates that the device is currently recording and makes the record_btn to function as 
a recording OFF button. 
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Repeat the steps to create a OnClick case for the settings button to turn the settings menu ON and setting the settingsOnOff variable to ON. 
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Open the OnClick case editor for the up_btn. 
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The up_btn opens the next page in the settings menu. Verify that the current state of the settingsPage variable is ‘1’ (1080p) and set to display 
the second settings page (720p) in the inline frame. Set the settingsPage variable to ‘2’. 
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Click on the Add Case… button to bring up the case editor and add Case 2 that would make the up button to show the third option in the 
settings menu. 
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Repeat the steps to create an additional case to show the fourth setting option. 
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Follow previous instructions and create OnClick cases for the down_btn, right_btn and left_btn to navigate through the Settings menu. 
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Select the settings_btn and click on the Add Case… button to bring up the Case Editor for Case 2. 
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Create actions to make the settings_btn to function as an Settings OFF button that would hide the settings menu when clicked. Set the 
settingsOnOff variable to OFF. 
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Repeat the steps to add a second case to record_btn to function as a Recording OFF button. 
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Add a second case to the power_btn to function as a Power OFF button and set the powerOnOff variable to OFF. This ensures that the 
power_btn will function as an ON button when it is clicked on the next time. 
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Click on the blue play icon to run a preview of the interactions. 
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The preview is loaded in browser for testing. Verify the document and save any changes made. 


