
This tutorial covers how to setup a file that can be used for augmented reality, virtual reality and online, interactive pre-
sentations.  Both methods of presenting require a obj or fbx format model with textures (label image files) mapped to 
the plygon sets.  The process involves several steps:

• Import the CAD model into KeyShot and setup initial materials
• Individually export each part in OBJ format
• Import OBJ files into Maya and create a group
• Setup materials including texture maps using projections
• Convert projection maps to file textures
• Export the in either OBJ or FBX format
• Compress the object, material and textures into a single file

Converting Project Maps to File Textures
Digital Modeling Series

Prof. Tim Purdy
School of Industrial Design
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To help keep the conversion process organized, start off by creating a Maya project.  Start Maya and then go to File > Project 
Window (A).  Click the New button, define a location and name for the project (B).  Not all the sub folders are needed.  Use the 
Edit > Clear Settings to remove the sub folders.  Fill back in the following sub folders (C).  To help keep track of the obj files, two 
unique folders will be added.  Open the Custom Data Loction tab and select the Add new file rule.  Add the two rules indicated 
below (D).  Click the Accept button to create the project and sub folders (E).

Step 1
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KeyShot will be used as a method to convert the CAD files to polygons.  Other tools such as Fusion 360 and Autodesk Show-
case can also export polygons. Import the model into KeyShot and setup basic materials.  You actually do not need to add labels 
but assign materials to the different parts.

Step 2



ID
@

G
T

P
ro

f. 
P

ur
dy

 - 
©

 2
01

7

Converting Project Maps to File Textures

Page 3

To export a model that has individual parts, the parts need to be exported one at a time.  Go to the top model in the Project 
Scene panel and turn it off.  Then turn one part back on.  In this example, the keyboard was made visible again.

Step 3
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Next, go to File > Export > Export to OBJ ...Step 4
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exportToMaya

A

B

It is best to export the parts into a separate folder (A).  Use the exportToMaya folder created with the project.  Confirm the file 
name, type and then choose Save.

Step 5
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exportToMaya exportToMaya

A

B

A

If a part consist of two different materials (in this example, the upper case), make sure to export them as two separate files from 
KeyShot.  Otherwise, Maya will import them as one mesh object (A) & (B).

Step 6
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exportToMaya

A

B

Items like the batteries are best re-imported as a single battery into KeyShot.  In this example, the batteries are visible as two 
separate objects although when exported, it will be one mesh.  Texture mapping maybe more of a challenge with geometry like 
this.

Step 7
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exportToMaya
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B

Continue to work through all the parts until each one has been exported.Step 8
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C

The Maya interface can be overwhelling with all the menus, tools and panel layouts. The next two steps will tailor the interface for 
the tutorial.  Most screens are shown as how they should look when finished. Select the Ploygons tab (A) to change the shelf. A 
majority of tools will come from this shelf.  Next, change the window layout (B) to side-by-side by clicking on the side bar icon as 
indicated.  The left panel needs to be changed to the Outliner.  At the top of the left window (C), select 
Panels > Panel > Outliner.  Adjust the width of the panel as needed.

Step 9

A

B
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The next step is to tailor the Hypershade.  This window allows you to create and edit materials in Maya.  Materials in Maya are 
called shaders.  When they have input/ouput connections, this is a shader network. To open it, go to Windos > Rendering Editors 
> Hypershade (A).  Not all the panel elements are required.  Close out the Material Viewer (B), the Property (C) editors and the 
create Panel (D).  If another panel shows up in the Create area, then close it as well.  Close the panel. It will be used later.  

Step 10
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In this Step, the individual OBJ files will be imported into Maya.  Select File > Import.  Make sure the File of Type (A) is set to the 
Obj format.  In the “Look in” drop down menu, locate the folder where the obj files were saved (B).  Pick the individual file (C) and 
click Import (D).  To view the full object, type the “f” for fit to window.  Repeat the process for the remaining obj files.  

Step 11

A

C
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This view of the Maya interfaces shows that all the obj files have been imported.  To select geometry, either use the Outliner in the 
left panel or click on it in the prespective window (A).  Attributes can be changed  by using the Channel box.  If the Channel box is 
not visible, click on the far right icon (B).  If you wanted to turn off the visibility of an object or multiply objects, highlight the “on” text 
in the Visibility channel and enter 0 and hit return (C).

Step 12
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To focus on texture mapping the keypad, select all the objects in the Outliner except for the keypad (A).  Attributes for multiply 
objects can be changed by using the Channel box.  If it is not visible, click on the far right icon (B).  Highlight the “on” text in the 
Visibility channel and enter 0 and hit return (C).

Step 12
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To get a size reference for the keypad graphics, switch to the Top view (A) and make a screen capture.  Use this reference image 
to layout the keypad graphics in the correct location (B).  In this example, Illustrator was used to create the keypad graphics.  Add 
in a background box with a color fill that matches the default color for the keypad.  Note: The keypad graphics file should match 
the reference file size (C).  Export the graphics out as an png format.  Make sure the resolution is high enough.  In this example, 
the vertical direction was exported above 2000 pixels per inch.

Step 14
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To project the image file onto the graphics, setup the interface with the Hypersade and Attribute editor.  in the left panel, go to 
Panels > Panel > Hypershade(A).  The Attribute editor can be open by clicking on the icon in the upper, left corner of the interface 
(B). 

Step 15
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In this step, a Projection map will be created on the Color channel.   Start by selecting the material already assigned to the key-
pad object (A).  This will load the selected material into the Attribute editor. Next, click on the checker icon to the right of the Color 
channel (B).  This will open the Create Render Node panel.  Right mouse click on the File texture source and choose Create a 
projection (C). 

Step 16



ID
@

G
T

P
ro

f. 
P

ur
dy

 - 
©

 2
01

7

Converting Project Maps to File Textures

Page 17
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To review the shading network that was created in the previous step, right-mouse click on the keypad shader ball (A).  The shad-
ing network should be frame within the editing window below (B).  Use the regular window scroll and zoom tools to better zoom in 
and frame the left side of the shader network. 

Step 17
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In this step, the image file will be selected and loaded into the shader network. Click on the “file1” node in the editing window (A).  
Click on the folder icon as indicated and navigate to the sourceimages folder (B).  Textures, labels, decals should be placed into 
the sourceimage folder that is part of the project folders setup at the begining.  Turn on the Hardware Texturing for the prespec-
tive. In the prespective window, select Shading > Hardware Texture (C).  Some of the texture should be visible on the keypad.

Step 18
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In this step, the Projection map will be adjusted to fit the 3D form.   Click on the “place3DTexture1” node int the editing window 
(A).  This will load the selected node into the Attribute editor. Next, select the “Fit to Group BBox” button (B).  The projection icon 
will reshape to fit the bounding box of the 3D form (C).  In this example, the projection icon is not oriented correctly.  It needs to 
be rotated and then resized again.  The next step will show you haw to do this. 

Step 19
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With the “place3DTexture1” node selected (A), type in “-90” degrees in the first column of the Rotate parameter in the Attribute 
editor (B).  This will orient the projection icon correctly for this example.  Next, select the “Fit to Group BBox” button again (C).  The 
projection icon will reshape to fit the bounding box of the 3D form (D).

Step 20
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Even if you used the reference image to size and place the graphics, usually tweeks of some type (overall and/or local translation 
or scaling) maybe required. Switch to the top orthographic view, Panels > Orthographic > top (A), to see how the graphics map 
onto the buttons.

Step 21
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In this view, the prespective window has been returned to the middle window and Hypershade has been closed.  A quick short-
cut is the single icon on the far left of the interface (A).  Notice the graphics do not look centered on the buttons and the green 
background  does not cover the button properly (B).

Step 22
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To make corrections, the texture map image was tweeked.  After the texture map was saved out, either use the Reload button (A) 
or select the folder icon (B) and select the texture map in the sourceimage folder.  Notice that the graphics has been fixed.

Step 23

A
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Once the texture map is corrected, the next step is to convert it from a projection map to a file map on the individual plygons.  
Start by switching back to the two panel view (A).  Change the left panel to the UV Editor (B). Select the keypad object in the pre-
spective window (C).  At this point, only the current texture image appears in the upper right corner of the UV editor graph (D).

Step 24
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Create an texture mapping for the ploygon set.  On the Polygons shelf, select the Automatic Mapping icon (A). Make sure the 
keypad object is selected prior to selecting the icon.  You should now see the ploygon sets laid out in the upper, right corner of 
the UV editor graph (B).

Step 25



ID
@

G
T

P
ro

f. 
P

ur
dy

 - 
©

 2
01

7

Converting Project Maps to File Textures

Page 26

A

B

C

Now it is time to convert the projection map to file texture.  Switch back to the Hypershade in the left panel (Panels > Panel > 
Hypershade).  Unselect the gemoetry by clicking on an exmpty area inthe garden and then repick it (A).  Make sure it highlights in 
green.  If not, face selection maybe still active.  Right-mouse click on the geometry and select Object from the upper right corner 
of the marking menu. Next, shift select the icon for the shader that is assigned to the keypad.  From the left panel menus, choose 
Edit > Convert to File Texture option box (C).  Make sure to click on the square box at the end of the menu to open the option box 
for this tool.

Step 26



ID
@

G
T

P
ro

f. 
P

ur
dy

 - 
©

 2
01

7

Converting Project Maps to File Textures

Page 27

Both must 
be selected
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A

In the Convert to File Texture Options box, scoll down to the X & Y Resolution (A).  This controls how large of a file that is created 
during this process.  Start off by making a large file (2048 x 2048 pixels).  The file resolution can easily be reduced using Photo-
shop or similar program if it is too large for interactive or VR/AR projects.  Select also the PNG for the File Format.  Select Convert 
and Close (B).  The program make take several seconds to complete the process.  

Step 27
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Visiually, the prespective window shoud look the same (A).  There will be a new shader icon in the upper sections of the Hyper-
shade (B).  Right-mouse click on it and choose Graph Network.  Notice that a simple network has been create (C).

Step 28
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Switch the left panel back to the UV Editor (Panels > Panel > UV Editor) (A). Select the keypad object in the prespective window 
(B).  Notice how the ploygon sets have now been mapped to an image that has been pieced together.

Step 29
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Before exporting the geometry, the texture image created in Step 27 needs to moved and reassigned.  In the project folder cre-
ated at the first step, copy the image, “projection1-keypad_Mesh.png”, into the exportFrom Maya folder (A).  Next, select the file 
texture in the Hypershade editor (B) and then click on the folder and select the copy in the exportFromMaya folder (C).

Step 30
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A

Make the geometry that was hidden earlier visible again.  Switch the left panel back to the Outliner and select the invisible geom-
etry (A). Type in “1” in the Visibility channel to make all them visible at once (B.

Step 31
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Select all the geometry objects in the Outliner (A) and go to File > Export Selection ... (B).Step 32
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Set the “Look In” folder to the exportFromMaya folder (A), name the file and then change the “Files of type” to Objexport (B).  
Make sure all the options are turn on (C) and select Export Selection button.

Step 33
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The final steps involves making a compressed file (.ZIP) from the exported files.  This is the file that is used to upload to the inter-
active presentation or AR/VR programs.  Select the obj, mtl and any texture image files (A) and compress them into a zip file.  Only 
the zip file needs to uploaded.

Step 34


